请选择 进入手机版 | 继续访问电脑版
 找回密码
 立即注册

QQ登录

只需一步,快速开始

小劍

注册会员

2

主题

5

帖子

119

积分

注册会员

积分
119
  • 379

    金币

  • 2

    主题

  • 5

    帖子

最新发帖

[已处理] 创建服务端webapi

小劍
注册会员   /  发表于:2024-1-31 12:11  /   查看:196  /  回复:2
5金币
活字格帮助文档中的服务端编程-创建服务端webapi时,
在这一步中,

“在NuGet管理器中,搜索并安装“Microsoft.AspNetCore.Http.Abstractions”。”
VS中显示此包已弃用,这个如何处理呢?




附件: 您需要 登录 才可以下载或查看,没有帐号?立即注册

最佳答案

查看完整内容

您想要升级 Microsoft.AspNetCore.Http.Abstractions 包,您需要注意以下几点: Microsoft.AspNetCore.Http.Abstractions 包在 ASP.NET Core 2.2 版本后已经被标记为过时,因为它已经被包含在 Microsoft.AspNetCore.App 框架引用中12。 因此,您不需要单独引用这个包,只需要在项目文件中添加以下元素: 添加后如图: ———————————————— 原文链接:https://b ...

2 个回复

倒序浏览
最佳答案
最佳答案
玉轩悬赏达人认证 活字格认证
金牌服务用户   /  发表于:2024-1-31 12:11:43
来自 2#
您想要升级 Microsoft.AspNetCore.Http.Abstractions 包,您需要注意以下几点:

Microsoft.AspNetCore.Http.Abstractions 包在 ASP.NET Core 2.2 版本后已经被标记为过时,因为它已经被包含在 Microsoft.AspNetCore.App 框架引用中12。

因此,您不需要单独引用这个包,只需要在项目文件中添加以下元素:
<ItemGroup>

<FrameworkReference Include="Microsoft.AspNetCore.App" />

</ItemGroup>

添加后如图:


————————————————

                        
原文链接:https://blog.csdn.net/hefeng_aspnet/article/details/134860881
请参考

评分

参与人数 1金币 +5 收起 理由
Joe.xu + 5 很给力!

查看全部评分

回复 使用道具 举报
Joe.xu讲师达人认证 悬赏达人认证 活字格认证
超级版主   /  发表于:2024-1-31 13:31:22
3#
感谢大家对活字格的支持
如果您的问题还未解决,欢迎跟帖补充;
如果您有新的问题,也欢迎创建新的求助帖呦。
回复 使用道具 举报
您需要登录后才可以回帖 登录 | 立即注册
返回顶部