请选择 进入手机版 | 继续访问电脑版
 找回密码
 立即注册

QQ登录

只需一步,快速开始

juebao

中级会员

41

主题

175

帖子

807

积分

中级会员

积分
807

微信认证勋章

juebao
中级会员   /  发表于:2016-10-15 10:58  /   查看:3026  /  回复:5
本帖最后由 Lenka.Guo 于 2016-10-17 09:45 编辑

在asp.net中,创建报表后,打开报以下错是怎么回事?
---------------------------
Microsoft Visual Studio
---------------------------
未能从程序集“mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089”中加载类型“System.Runtime.CompilerServices.ExtensionAttribute”。
---------------------------
确定   
---------------------------

5 个回复

倒序浏览
Lenka.Guo讲师达人认证 悬赏达人认证
超级版主   /  发表于:2016-10-17 09:39:43
沙发
这个是可能是项目的问题,是不是您的.net framework 框架版本不一致导致运行时抛出异常?
回复 使用道具 举报
juebao
中级会员   /  发表于:2016-10-17 09:51:34
板凳
Lenka.Guo 发表于 2016-10-17 09:39
这个是可能是项目的问题,是不是您的.net framework 框架版本不一致导致运行时抛出异常?

但是其他的项目页面都没有问题,就报表打不开,我新建了一个项目,也不行
回复 使用道具 举报
Lenka.Guo讲师达人认证 悬赏达人认证
超级版主   /  发表于:2016-10-17 09:58:42
地板
juebao 发表于 2016-10-17 09:51
但是其他的项目页面都没有问题,就报表打不开,我新建了一个项目,也不行

那麻烦您把出问题的报表项目发过来,我在这边测试重现下问题。
回复 使用道具 举报
juebao
中级会员   /  发表于:2016-10-17 11:51:21
5#
Lenka.Guo 发表于 2016-10-17 09:58
那麻烦您把出问题的报表项目发过来,我在这边测试重现下问题。

已经解决了,是framework的问题,在机器上装个4.5的版本就可以,以前的是4.0的,好像不行
回复 使用道具 举报
Lenka.Guo讲师达人认证 悬赏达人认证
超级版主   /  发表于:2016-10-17 12:23:13
6#
juebao 发表于 2016-10-17 11:51
已经解决了,是framework的问题,在机器上装个4.5的版本就可以,以前的是4.0的,好像不行

好的,谢谢反馈
回复 使用道具 举报
您需要登录后才可以回帖 登录 | 立即注册
返回顶部