请选择 进入手机版 | 继续访问电脑版
 找回密码
 立即注册

QQ登录

只需一步,快速开始

armgong
金牌服务用户   /  发表于:2015-12-29 16:19  /   查看:4075  /  回复:3
今天正在尝试使用spreadjs 9 导出时,我们的项目使用 ASP webapi vs2015,创建一个空的webapi项目直接就依赖Newtonsoft.Json 6.0.0.0, 但是你们的excelio组件依赖 Newtonsoft.Json 4.5.11. 请问如何解决?

3 个回复

倒序浏览
frank.zhang
社区贡献组   /  发表于:2015-12-29 16:26:00
沙发
您好,

您的问题,我们已经收到,会尽快联系产品组,由于开发人员有美国,有时差影响,会有1到2个工作日的延迟。
回复 使用道具 举报
armgong
金牌服务用户   /  发表于:2015-12-29 16:42:00
板凳
已经部分解决了,通过修改 web.conf
     <dependentAssembly>
        <assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-8.0.0.0" newVersion="8.0.0.0" />
      </dependentAssembly>

但是不知道这有没有副作用,毕竟你们的版本是4.5.11,vs的版本是6.0.0.0,如果Newtonsoft.Json 的向下兼容性好的话还行,否则不知道会出什么问题?还是让你们的开发看看吧,最好是能够把自带的Newtonsoft.Json 升升级

评分

参与人数 1金币 +999 收起 理由
frank.zhang + 999 反馈建议

查看全部评分

回复 使用道具 举报
frank.zhang
社区贡献组   /  发表于:2015-12-29 17:49:00
地板
您好,

您的这个方法是正确的解决方案。

您的建议,我会反馈给产品组。感谢您的建议。给您分发 1000 金币。可以用于兑换论坛奖品。
金币规则:点击进入
礼品列表:点击进入
回复 使用道具 举报
您需要登录后才可以回帖 登录 | 立即注册
返回顶部